Changer la version de PHP utilisée en ligne de commande

Lorsque plusieurs versions de PHP sont installées sur le serveur, un lien symbolique est créé par défaut pour que l’on puisse appeler une exécution de commandes PHP sans indiquer la version de celui-ci simplement en tapant : php.

Mais dans certains cas, la version du PHP n’est pas compatible avec les scripts à exécuter. Il faut donc changer le lien symbolique pour pointer sur la bonne version du PHP.

#Aller dans le dossier
cd /usr/bin/

#Vérifier le pointage de PHP
ls -al php

#Modifier la version du PHP utilisé par défaut
ln -sfn /usr/bin/php7.3 ./php

#Vérifier la version utilisée
php -version